packages: uboot-mxs: bless UBOOT_IMAGE with a meaning
[openwrt/svn-archive/archive.git] / package / boot / uboot-mxs / Makefile
index 532c7a58ca3fee47a799d442a493447e4af040b8..373b8d8f80ed288103c216e296cb973e811d25c7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2015.01
+PKG_VERSION:=2015.07
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=7f08dc9e98a71652bd6968888ed6ec95
+PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
@@ -30,17 +30,16 @@ define uboot/Default
 endef
 
 define uboot/mx23_olinuxino
-  TITLE:=U-Boot 2015.01 for the Olinuxino i.MX233
+  TITLE:=U-Boot 2015.07 for the Olinuxino i.MX233
 endef
 
 define uboot/duckbill
-  TITLE:=U-Boot 2015.01 for the I2SE Duckbill
+  TITLE:=U-Boot 2015.07 for the I2SE Duckbill
 endef
 
 UBOOTS := \
        mx23_olinuxino \
        duckbill
-       
 
 define Package/uboot/template
 define Package/uboot-mxs-$(1)
@@ -63,7 +62,7 @@ endef
 ifdef BUILD_VARIANT
 $(eval $(call uboot/$(BUILD_VARIANT)))
 UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
+UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),u-boot.sb)
 endif
 
 define Build/Configure
@@ -73,13 +72,12 @@ endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CROSS_COMPILE=$(TARGET_CROSS) u-boot.sb
+               CROSS_COMPILE=$(TARGET_CROSS) $(UBOOT_IMAGE)
 endef
 
-
 define Package/uboot/install/default
        $(INSTALL_DIR) $(BIN_DIR)/uboot-$(BOARD)-$(1)
-       dd if=$(PKG_BUILD_DIR)/u-boot.sb of=$(BIN_DIR)/uboot-$(BOARD)-$(1).sb bs=512 seek=4
+       $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(BIN_DIR)/uboot-$(BOARD)-$(1)/uboot-$(BOARD)-$(1).sb
 endef
 
 define Package/uboot/install/template