upgrade bridge-utils to v1.4
[openwrt/svn-archive/archive.git] / package / bridge-utils / Makefile
index e9f2de5aa91365bc27032e7a0ad4cd8137b11000..de9bc95d7ab957414002c96b4e9fe97f2dd5ac51 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=bridge-utils
-PKG_VERSION:=1.0.6
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/bridge
-PKG_MD5SUM:=9b7dc52656f5cbec846a7ba3299f73bd
+PKG_MD5SUM:=0182fcac3a2b307113bbec34e5f1c673
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -34,6 +34,13 @@ endef
 CONFIGURE_ARGS += \
        --with-linux-headers="$(LINUX_DIR)" \
 
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+       autoconf; \
+       ./configure $(CONFIGURE_ARGS) \
+       )
+endef
+
 define Package/bridge/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin/