replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / package / bridge / Makefile
index c186c8e701c174452e9ecbd98fbcbd617dcbc9a6..0091af5a23337213081af0d6135ddd5757bd5d96 100644 (file)
@@ -24,7 +24,6 @@ include $(INCLUDE_DIR)/package.mk
 define Package/bridge
   SECTION:=net
   CATEGORY:=Base system
-  DEFAULT:=y
   TITLE:=Ethernet bridging configuration utility
   DESCRIPTION:=\
        Manage ethernet bridging: a way to connect networks together to \\\
@@ -39,8 +38,8 @@ define Build/Configure
 endef
 
 define Package/bridge/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/brctl/brctl $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,bridge))