replace gen_busybox_config.pl with a simple sed command
[openwrt/svn-archive/archive.git] / package / busybox / Makefile
index 90e3af060aeeb039db645fb62035180b5e77b513..03a0ebd54927964f7f456407924765dce496b0b2 100644 (file)
@@ -51,7 +51,7 @@ endef
 
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \