replace gen_busybox_config.pl with a simple sed command
[openwrt/svn-archive/archive.git] / package / busybox / Makefile
index c1944722e340aaee14a2e5ad3f9d00e990718ed7..03a0ebd54927964f7f456407924765dce496b0b2 100644 (file)
@@ -9,19 +9,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.4.0
+PKG_VERSION:=1.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=f24a3c1e08bc55ec44381d588e8bcced
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
 
 include $(INCLUDE_DIR)/package.mk
 
+ifeq ($(DUMP),)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+endif
+
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
@@ -41,6 +42,7 @@ The Swiss Army Knife of embedded Linux.
 endef
 
 define Package/busybox/config
+       source "$(SOURCE)/target-config.in"
        menu "Configuration"
                depends on PACKAGE_busybox
                source "$(SOURCE)/config/Config.in"
@@ -48,7 +50,8 @@ define Package/busybox/config
 endef
 
 define Build/Configure
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       rm -f $(PKG_BUILD_DIR)/.configured*
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \