Small bug fix to package/kernel/modules/other.mk
[openwrt/svn-archive/archive.git] / package / busybox / Makefile
index 2927d70436c34ac72f821089fadbcb9ee1fc4745..3e6cc4e9c9208dbb4656dfff50b2e9af56d74624 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.3.1
+PKG_VERSION:=1.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=571531cfa83726947ccb566de017ad4f
+PKG_MD5SUM:=5728403bce309cdabcffa414e2e64052
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -41,6 +41,7 @@ The Swiss Army Knife of embedded Linux.
 endef
 
 define Package/busybox/config
+       source "$(SOURCE)/target-config.in"
        menu "Configuration"
                depends on PACKAGE_busybox
                source "$(SOURCE)/config/Config.in"
@@ -75,7 +76,7 @@ define Package/busybox/install
                IPKG_ARCH="$(ARCH)" \
                CONFIG_PREFIX="$(1)" \
                install
-       mkdir -p $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/init.d
        for tmp in $(init-y); do \
                $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
        done