ath9k: fix counter overflow in survey channel time stats for the operating channel
[openwrt/svn-archive/archive.git] / package / busybox / Makefile
index 0c1efc470aa912d44f07f11a7e265cd4e0b0c643..4ea9a61e4eb79453a103c1008333f6b3ddb5516a 100644 (file)
@@ -1,26 +1,29 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.2.1
+PKG_VERSION:=1.17.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=362b3dc0f2023ddfda901dc1f1a74391
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=http://www.busybox.net/downloads \
+               http://distfiles.gentoo.org/distfiles/
+PKG_MD5SUM:=7360b7138b899ee7fc885791c740c3c3
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+ifeq ($(DUMP),)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+endif
+
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_HTTPD) += httpd
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
@@ -29,49 +32,63 @@ init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
+  MAINTAINER:=Nicolas Thill <nico@openwrt.org>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
   MENU:=1
 endef
 
 define Package/busybox/description
-The Swiss Army Knife of embedded Linux.
      It slices, it dices, it makes Julian Fries.
+ The Swiss Army Knife of embedded Linux.
+ It slices, it dices, it makes Julian Fries.
 endef
 
 define Package/busybox/config
-       menu "Configuration"
-               depends on PACKAGE_busybox
-               source "$(SOURCE)/config/Config.in"
-       endmenu
+       source "$(SOURCE)/Config.in"
 endef
 
 define Build/Configure
-       $(SCRIPT_DIR)/gen_busybox_config.pl $(TOPDIR)/.config > $(PKG_BUILD_DIR)/.config
+       rm -f $(PKG_BUILD_DIR)/.configured*
+       grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
        yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               CROSS="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KBUILD_HAVE_NLS=no \
+               ARCH="$(ARCH)" \
                oldconfig
 endef
 
+ifdef CONFIG_GCC_VERSION_LLVM
+  TARGET_CFLAGS += -fnested-functions
+endif
+
+ifdef CONFIG_GCC_VERSION_4_5_0
+  TARGET_CFLAGS += -fno-tree-pta
+endif
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               CROSS="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               KBUILD_HAVE_NLS=no \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
-               IPKG_ARCH="$(ARCH)" \
+               ARCH="$(ARCH)" \
+               SKIP_STRIP=y \
                all
-endef
-
-define Package/busybox/install
+       rm -rf $(PKG_INSTALL_DIR)
+       $(FIND) $(PKG_BUILD_DIR) -lname "*busybox" -exec rm \{\} \;
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               CROSS="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
-               IPKG_ARCH="$(ARCH)" \
-               PREFIX="$(1)" \
+               ARCH="$(ARCH)" \
+               CONFIG_PREFIX="$(PKG_INSTALL_DIR)" \
                install
-       mkdir -p $(1)/etc/init.d
+endef
+
+define Package/busybox/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
        for tmp in $(init-y); do \
                $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
        done