disable a totally braindead optimization in busybox that causes various applets to...
[openwrt/svn-archive/archive.git] / package / busybox / Makefile
index 044eae2f9d7aba86daefdaf9fafb654def3434b8..fc935d82940679e55cd7e896070539dd0407134a 100644 (file)
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.4.2
-PKG_RELEASE:=2
+PKG_VERSION:=1.8.1
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
                http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=b4c61fb15642be9dde20e8493788c585
+PKG_MD5SUM:=c54554851d989328654a3eeab915a04f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -37,14 +37,14 @@ define Package/busybox
 endef
 
 define Package/busybox/description
-The Swiss Army Knife of embedded Linux.
      It slices, it dices, it makes Julian Fries.
+ The Swiss Army Knife of embedded Linux.
+ It slices, it dices, it makes Julian Fries.
 endef
 
 define Package/busybox/config
-       source "$(SOURCE)/target-config.in"
        menu "Configuration"
                depends on PACKAGE_busybox
+               source "$(SOURCE)/target-config.in"
                source "$(SOURCE)/config/Config.in"
        endmenu
 endef