[package] comgt: add tty hotplug remove handling, only iterate each tty once (#9211)
[openwrt/svn-archive/archive.git] / package / comgt / Makefile
index 606f2f1bcf8ae60699416e4a6683c0d4a2810f37..00c111811303e02dc60e0db35ae4596390d03dcc 100644 (file)
@@ -1,16 +1,15 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=1
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -25,7 +24,7 @@ define Package/comgt
   CATEGORY:=Utilities
   TITLE:=Option/Vodafone 3G/GPRS control tool
   DEPENDS:=+chat
-  URL:= http://www.pharscape.org/content/view/46/70/
+  URL:=http://www.pharscape.org/comgt.html
 endef
 
 define Package/comgt/description
@@ -48,12 +47,15 @@ define Package/comgt/install
        $(INSTALL_BIN) ./files/3g.connect $(1)/etc/ppp/3g.connect
        $(INSTALL_DIR) $(1)/etc/chatscripts
        $(INSTALL_DATA) ./files/3g.chat $(1)/etc/chatscripts/3g.chat
+       $(INSTALL_DATA) ./files/evdo.chat $(1)/etc/chatscripts/evdo.chat
        $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files/3g.sh $(1)/lib/network/3g.sh
+       $(INSTALL_BIN) ./files/3g.sh $(1)/lib/network/3g.sh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/button
        $(INSTALL_DATA) ./files/3g.button $(1)/etc/hotplug.d/button/05-3g
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/3g.iface $(1)/etc/hotplug.d/iface/05-3g
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
+       $(INSTALL_DATA) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/etc/gcom
        $(INSTALL_DATA) ./files/setpin.gcom $(1)/etc/gcom/setpin.gcom
        $(INSTALL_DATA) ./files/setmode.gcom $(1)/etc/gcom/setmode.gcom