rpcd: iwinfo plugin fixes
[openwrt/svn-archive/archive.git] / package / devel / valgrind / Makefile
index d17a78147ce25be1206ef57edb0eae766665dc76..6a576a24d0000998e8029cbf28864bb13caac815 100644 (file)
@@ -8,18 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=valgrind
-PKG_VERSION:=3.8.1
+PKG_VERSION:=3.10.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://valgrind.org/downloads/
-PKG_MD5SUM:=288758010b271119a0ffc0183f1d6e38
+PKG_MD5SUM:=60ddae962bc79e7c95cfc4667245707f
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+PKG_LICENSE:=GPL-2.0+
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
 PKG_BUILD_PARALLEL := 1
+PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -27,7 +29,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||i386||powerpc||arm_v7 +libpthread +librt
+  DEPENDS:=@mips||mipsel||i386||x86_64||powerpc||arm_v7 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef
@@ -76,20 +78,31 @@ define Package/valgrind/description
        to speed up and reduce memory use of your programs.
 endef
 
-CPU := $(patsubst x86,i386,$(LINUX_KARCH))
+CPU := $(patsubst x86_64,amd64,$(patsubst x86,i386,$(patsubst um,$(ARCH),$(LINUX_KARCH))))
 
 CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
+ifeq ($(ARCH),x86_64)
+       CONFIGURE_ARGS += \
+               --enable-only64bit
+       BITS := 64bit
+else
+       CONFIGURE_ARGS += \
+               --enable-only32bit
+       BITS := 32bit
+endif
+
 CONFIGURE_ARGS += \
-       --enable-only32bit \
        --enable-tls \
        --without-x \
+       --without-mpicc \
        --without-uiout \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin
@@ -100,8 +113,8 @@ define Package/valgrind/install
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/none-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_core*.so \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(CPU)-*.xml \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-core*.xml \
-               $(PKG_INSTALL_DIR)/usr/lib/valgrind/32bit-linux*.xml \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-core*.xml \
+               $(PKG_INSTALL_DIR)/usr/lib/valgrind/$(BITS)-linux*.xml \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/memcheck-* \
                $(PKG_INSTALL_DIR)/usr/lib/valgrind/vgpreload_memcheck*.so \
                $(1)/usr/lib/valgrind/