disable mips16 for a few packages that don't compile with it
[openwrt/svn-archive/archive.git] / package / devel / valgrind / Makefile
index b3fb210a41b5f41abf858d4735c4253d67609f7a..6c22348cff2133244eae4876b1f5bfaeb15b6e2f 100644 (file)
@@ -19,6 +19,8 @@ PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
 PKG_FIXUP = autoreconf
 PKG_INSTALL := 1
+PKG_BUILD_PARALLEL := 1
+PKG_USE_MIPS16:=0
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -26,7 +28,7 @@ include $(INCLUDE_DIR)/kernel.mk
 define Package/valgrind
   SECTION:=devel
   CATEGORY:=Development
-  DEPENDS:=@mips||mipsel||i386||powerpc||TARGET_omap4 +libpthread +librt
+  DEPENDS:=@mips||mipsel||i386||powerpc||arm_v7 +libpthread +librt
   TITLE:=debugging and profiling tools for Linux
   URL:=http://www.valgrind.org
 endef