[package] update dnsmasq to 2.47 (#4636, thanks florida)
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index a14970a9db084598bb7a42aae3501e0b0f465049..06bcbfcce019a59873797539df66eae07b0400d5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.43
+PKG_VERSION:=2.47
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=3222690c6f1f919bcefcf01a632508af
+PKG_MD5SUM:=4524081e56d0b935717d493e8e8d3e11
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +29,10 @@ define Package/dnsmasq/description
  It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
+define Package/dnsmasq/conffiles
+/etc/config/dhcp
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \