package/dnsmasq: use new service wrapper
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index 5fe1509601c04bdb311004f62bbf27407eb92463..1294a8b45fa897c40f15be49936b1d76d6776fd4 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.47
-PKG_RELEASE:=3
+PKG_VERSION:=2.58
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=4524081e56d0b935717d493e8e8d3e11
+PKG_MD5SUM:=14c5c81debb324adc261db971730f4c6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,19 +25,24 @@ define Package/dnsmasq
 endef
 
 define Package/dnsmasq/description
- It is intended to provide coupled DNS and DHCP service to a LAN.
 It is intended to provide coupled DNS and DHCP service to a LAN.
 endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
-               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               BINDIR="/usr/sbin" \
+               MANDIR="/usr/man" \
                AWK="awk" \
+               LDFLAGS="-Wl,--gc-sections" \
                all
 endef
 
@@ -47,6 +51,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef