package/dnsmasq: use new service wrapper
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index cb723d528f1c47a55f1aa37e6e0ee73c7803d409..1294a8b45fa897c40f15be49936b1d76d6776fd4 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.40
-PKG_RELEASE:=1
+PKG_VERSION:=2.58
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=91b6063ae81146b9d70b4381b2f3e44f
+PKG_MD5SUM:=14c5c81debb324adc261db971730f4c6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,19 +24,25 @@ define Package/dnsmasq
   URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
+define Package/dnsmasq/description
+  It is intended to provide coupled DNS and DHCP service to a LAN.
+endef
+
 define Package/dnsmasq/conffiles
+/etc/config/dhcp
 /etc/dnsmasq.conf
 endef
 
-define Package/dnsmasq/description
- It is intended to provide coupled DNS and DHCP service to a LAN.
-endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
-               BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               BINDIR="/usr/sbin" \
+               MANDIR="/usr/man" \
+               AWK="awk" \
+               LDFLAGS="-Wl,--gc-sections" \
                all
 endef