Add default /etc/dnsmasq.conf
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index 3444efefff043c7a8d888e98cfeda1d682c791c4..176e5b93d322e9e6fefcf75f9b0c007e2c26f705 100644 (file)
@@ -30,6 +30,7 @@ endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
 define Build/Compile
@@ -46,6 +47,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef