[mac80211] adds ath5k platfrom_device eep support
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index 540d47689edc7f1d4e7f4b4f4567e0e8527df5c2..9fc70b3daffe22626016003a4b62156d2bf1c150 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.58
-PKG_RELEASE:=1
+PKG_VERSION:=2.59
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=14c5c81debb324adc261db971730f4c6
+PKG_MD5SUM:=b5757ef2d7b651748eeebb88af29d7d6
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,22 +35,19 @@ define Package/dnsmasq/conffiles
 /etc/dnsmasq.conf
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               BINDIR="/usr/sbin" \
-               MANDIR="/usr/man" \
-               AWK="awk" \
-               LDFLAGS="-Wl,--gc-sections" \
-               all
-endef
+TARGET_CFLAGS += \
+       -ffunction-sections -fdata-sections \
+       $(if $(CONFIG_IPV6),,-DNO_IPV6)
+
+MAKE_FLAGS := \
+       $(TARGET_CONFIGURE_OPTS) \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LDFLAGS="-Wl,--gc-sections" \
+       PREFIX="/usr"
 
 define Package/dnsmasq/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
        $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf