[mac80211] adds ath5k platfrom_device eep support
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index a2084a616cdd79d3a9dbbcd80fc209983d97e325..9fc70b3daffe22626016003a4b62156d2bf1c150 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.59
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
@@ -35,7 +35,9 @@ define Package/dnsmasq/conffiles
 /etc/dnsmasq.conf
 endef
 
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_CFLAGS += \
+       -ffunction-sections -fdata-sections \
+       $(if $(CONFIG_IPV6),,-DNO_IPV6)
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \