package/dnsmasq: bump release number (missed from r21400)
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index d0beeb6f49b9a0b4886da13e41decd55b08db39e..a984a3dd5d6bdb4b5d696e00fa6679a44b5ad6b7 100644 (file)
@@ -1,23 +1,19 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.33
-PKG_RELEASE:=1
+PKG_VERSION:=2.52
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=45696461b6e6bc929273b1191ca50447
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=1bb32fffdb4f977ead607802b5d701d0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,30 +21,35 @@ define Package/dnsmasq
   SECTION:=net
   CATEGORY:=Base system
   TITLE:=A lightweight DNS and DHCP server
-  DESCRIPTION:=\
-       It is intended to provide coupled DNS and DHCP service to a LAN.
   URL:=http://www.thekelleys.org.uk/dnsmasq/
 endef
 
+define Package/dnsmasq/description
+ It is intended to provide coupled DNS and DHCP service to a LAN.
+endef
+
 define Package/dnsmasq/conffiles
+/etc/config/dhcp
 /etc/dnsmasq.conf
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
+               AWK="awk" \
                all
 endef
 
 define Package/dnsmasq/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
-       install -m0755 -d $(1)/etc
-       install -m0644 ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef
 
 $(eval $(call BuildPackage,dnsmasq))