dnsmasq: use -ffunction-sections, -fdata-sections and --gc-sections, saves 8k uncompr...
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index 97f5d094df7d347c7374cc60319462d5b9866be5..b71db58587a68f098fbea17ebc4bce192f44289f 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.46
+PKG_VERSION:=2.57
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=79ec740d1a10ee75f13efa4ff36d0250
+PKG_MD5SUM:=d10faeb409717eae94718d7716ca63a4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,14 +30,18 @@ endef
 
 define Package/dnsmasq/conffiles
 /etc/config/dhcp
+/etc/dnsmasq.conf
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
                AWK="awk" \
+               LDFLAGS="-Wl,--gc-sections" \
                all
 endef
 
@@ -47,6 +50,7 @@ define Package/dnsmasq/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+       $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
 endef