dnsmasq: use -ffunction-sections, -fdata-sections and --gc-sections, saves 8k uncompr...
[openwrt/svn-archive/archive.git] / package / dnsmasq / Makefile
index a3223431f3cf16261afd3215429e19f6e37406f2..b71db58587a68f098fbea17ebc4bce192f44289f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.51
-PKG_RELEASE:=3
+PKG_VERSION:=2.57
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=97465261a6de5258a3c3edfe51ca16a4
+PKG_MD5SUM:=d10faeb409717eae94718d7716ca63a4
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,12 +33,15 @@ define Package/dnsmasq/conffiles
 /etc/dnsmasq.conf
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_ISC_READER=1" \
+               CFLAGS="$(TARGET_CFLAGS)" \
                BINDIR="/usr/sbin" MANDIR="/usr/man" \
                AWK="awk" \
+               LDFLAGS="-Wl,--gc-sections" \
                all
 endef