From: Joseph Roback <openwrt-devel@roback.cc>
[openwrt/svn-archive/archive.git] / package / dropbear / Makefile
index 77d6d9707b04e4ec166cb2ef793423a64d5e0d1d..6fad273660a4f160dcea3dfe778fd1ea54c54a9e 100644 (file)
@@ -17,6 +17,8 @@ PKG_SOURCE_URL:= \
        http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
 PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
 
        http://www.mirrors.wiretapped.net/security/cryptography/apps/ssh/dropbear/
 PKG_MD5SUM:=1c69ec674481d7745452f68f2ea5597e
 
+PKG_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dropbear/Default
 include $(INCLUDE_DIR)/package.mk
 
 define Package/dropbear/Default
@@ -70,12 +72,12 @@ define Build/Configure
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
                PROGRAMS="dropbear dbclient dropbearkey scp" \
                MULTI=1 SCPPROGRESS=1
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
                PROGRAMS="dropbear dbclient dropbearkey scp" \
                MULTI=1 SCPPROGRESS=1
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
                PROGRAMS="dropbearconvert"
                $(TARGET_CONFIGURE_OPTS) \
                LD="$(TARGET_CC)" \
                PROGRAMS="dropbearconvert"