add $(STAGING_DIR) as argument to the InstallDev template and update packages accordi...
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index 1d56bacc8a3064b9d99c3cad5606c6adfb953fc7..16102907ae5500e5bacb77c5d598f0823323149d 100644 (file)
@@ -18,47 +18,56 @@ PKG_MD5SUM:=06f7806782e357797fad1d34b7ced0c6
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/e2fsprogs/Default
+  URL:=http://e2fsprogs.sourceforge.net/
+endef
+
 define Package/e2fsprogs
+$(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libuuid
-  DESCRIPTION:=\
-       This package contains essential ext2 filesystem utilities which consists of \\\
-       e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2 \\\
-       filesystem utilities.
+  DEPENDS:=+libblkid +libuuid
+endef
+
+define Package/e2fsprogs/description
+ This package contains essential ext2 filesystem utilities which consists of 
+ e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2 
+ filesystem utilities.
 endef
 
 define Package/libuuid
+$(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=DCE compatible Universally Unique Identifier library
-  DESCRIPTION:=\
-               Library for generating DCE compatible Universally Unique Identifiers
-  URL:=http://e2fsprogs.sourceforge.net/
+endef
+
+define Package/libuuid/description
+ Library for generating DCE compatible Universally Unique Identifiers.
 endef
 
 define Package/libblkid
+$(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=block device id library
-  DESCRIPTION:=\
-       The blkid library which allows system programs like fsck and mount to quickly\\\
-       and easily find block devices by filesystem UUID and LABEL.
-  URL:=http://e2fsprogs.sourceforge.net/
+endef
+
+define Package/libblkid/description
+ The blkid library which allows system programs like fsck and mount to 
+ quickly and easily find block devices by filesystem UUID and LABEL.
 endef
 
 define Package/tune2fs
-  $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
-  DESCRIPTION:=Ext2 Filesystem tune utility
   DEPENDS:=e2fsprogs
 endef
 
 define Package/resize2fs
-  $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem resize utility
-  DESCRIPTION:=Ext2 Filesystem resize utility
   DEPENDS:=e2fsprogs
 endef
 
@@ -69,6 +78,11 @@ CONFIGURE_ARGS += \
        --enable-elf-shlibs \
        --enable-dynamic-e2fsck
 
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/config/
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/util \
                BUILDCC="$(HOSTCC)" \
@@ -85,8 +99,17 @@ endef
 define Build/InstallDev
        $(MAKE) -C $(PKG_BUILD_DIR) \
                BUILDCC="$(HOSTCC)" \
-               DESTDIR="$(STAGING_DIR)" \
+               DESTDIR="$(1)" \
                install-libs
+       $(SED) 's,-I$$$${includedir},,g' $(1)/usr/lib/pkgconfig/{blkid,com_err,e2p,ext2fs,ss,uuid}.pc
+       $(SED) 's,-L$$$${libdir},,g' $(1)/usr/lib/pkgconfig/{blkid,com_err,e2p,ext2fs,ss,uuid}.pc
+endef
+
+define Build/UninstallDev
+       -$(MAKE) -C $(PKG_BUILD_DIR) \
+               BUILDCC="$(HOSTCC)" \
+               DESTDIR="$(STAGING_DIR)" \
+               uninstall-libs
 endef
 
 define Package/e2fsprogs/install
@@ -96,7 +119,7 @@ define Package/e2fsprogs/install
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach lib,blkid com_err e2p ext2fs,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(CP) $(foreach lib,com_err e2p ext2fs,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
 endef
 
 define Package/libuuid/install
@@ -105,7 +128,7 @@ define Package/libuuid/install
 endef
 
 define Package/libblkid/install
-       $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
 endef