mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index 3a08db3238fee7ff64f9e2abd38a31188e689eb0..3a6a966937e590ece780be44a6daa9c4f7a7259d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 # Copyright 2010 Vertical Communications
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.40.11
-PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_VERSION:=1.41.12
+PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/e2fsprogs/Default
@@ -64,7 +66,7 @@ define Package/libblkid
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=block device id library
+  TITLE:=Block device id library
 endef
 
 define Package/libblkid/description
@@ -132,7 +134,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                BUILDCC="$(HOSTCC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               all
 endef
 
 define Build/InstallDev
@@ -158,6 +160,7 @@ define Package/e2fsprogs/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/lib/functions/fsck
        $(INSTALL_DATA) ./files/e2fsck.sh $(1)/lib/functions/fsck/
+       $(INSTALL_DATA) ./files/e2fsck.conf $(1)/etc/e2fsck.conf
 endef
 
 define Package/libuuid/install