ath9k: fix reliability issues with TKIP MIC verification
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index a6b2d1570740693625b5491c11464da7f7a3d88b..aac0c5e5be3e9e031c7439abc1108f9a3ff8556c 100644 (file)
@@ -1,33 +1,35 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
-#
+# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright 2010 Vertical Communications
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.40.11
-PKG_RELEASE:=1
+PKG_VERSION:=1.41.12
+PKG_MD5SUM:=1b24a21fc0c2381ef420961cbfec733f
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/e2fsprogs/Default
   URL:=http://e2fsprogs.sourceforge.net/
+  SUBMENU:=Filesystem
 endef
 
 define Package/e2fsprogs
 $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs
+  TITLE:=Ext2/3/4 filesystem utilities
+  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread +libcom_err
 endef
 
 define Package/e2fsprogs/description
@@ -49,7 +51,7 @@ endef
 
 define Package/uuidgen
 $(call Package/e2fsprogs)
-  DEPENDS:=libuuid
+  DEPENDS:=+libuuid
   TITLE:=Command line utility to create a new UUID value
 endef
 
@@ -64,7 +66,7 @@ define Package/libblkid
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=block device id library
+  TITLE:=Block device id library
 endef
 
 define Package/libblkid/description
@@ -76,31 +78,50 @@ define Package/libext2fs
 $(call Package/e2fsprogs/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=ext2/ext3 filesystem library
+  TITLE:=ext2/3/4 filesystem library
 endef
 
 define Package/libext2fs/description
-libext2fs is a library which can access ext2 and ext3 filesystems.
+libext2fs is a library which can access ext2, ext3 and ext4 filesystems.
+endef
+
+define Package/libcom_err
+$(call Package/e2fsprogs/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Common error description library
+endef
+
+define Package/libcom_err/description
+libcom_err is a library providing common error descriptions
 endef
 
 define Package/tune2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
 define Package/resize2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem resize utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
 define Package/badblocks
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem badblocks utility
-  DEPENDS:=e2fsprogs
+  DEPENDS:= +e2fsprogs
 endef
 
+define Package/blkid
+$(call Package/e2fsprogs)
+  TITLE:=Command-line utility to locate/print block device attributes
+  DEPENDS:=+libuuid +libblkid +libext2fs +libcom_err +libpthread
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -124,7 +145,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                BUILDCC="$(HOSTCC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+               all
 endef
 
 define Build/InstallDev
@@ -144,8 +165,18 @@ define Package/e2fsprogs/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
+       ln -sf mke2fs $(1)/usr/sbin/mkfs.ext4
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libe2p.so.* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/lib/functions/fsck
+       $(INSTALL_DATA) ./files/e2fsck.sh $(1)/lib/functions/fsck/
+       $(INSTALL_DATA) ./files/e2fsck.conf $(1)/etc/e2fsck.conf
+endef
+
+define Package/libcom_err/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libcom_err.so.* $(1)/usr/lib/
 endef
 
 define Package/libuuid/install
@@ -165,7 +196,7 @@ endef
 
 define Package/libext2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so.* $(1)/usr/lib/
 endef
 
 define Package/tune2fs/install
@@ -183,11 +214,18 @@ define Package/badblocks/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
+define Package/blkid/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,uuidgen))
 $(eval $(call BuildPackage,libblkid))
 $(eval $(call BuildPackage,libext2fs))
+$(eval $(call BuildPackage,libcom_err))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
+$(eval $(call BuildPackage,blkid))