[package] update e2fsprogs to v1.41.5 (#5014)
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index e01828eacb1d4f24d46cdd47cee1ce018cb2ffc1..ca5cb082bfc086a218516565eaea1bd8dff73988 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.40.11
-PKG_RELEASE:=2
+PKG_VERSION:=1.41.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_MD5SUM:=e218df6c84fc17c1126d31de9472a76c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -101,6 +100,12 @@ $(call Package/e2fsprogs)
   DEPENDS:=e2fsprogs
 endef
 
+define Package/blkid
+$(call Package/e2fsprogs)
+  TITLE:=Command-line utility to locate/print block device attributes
+  DEPENDS:=libuuid libblkid
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -146,6 +151,9 @@ define Package/e2fsprogs/install
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/e2fsck.init $(1)/etc/init.d/e2fsck
+
 endef
 
 define Package/libuuid/install
@@ -183,6 +191,11 @@ define Package/badblocks/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
+define Package/blkid/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,uuidgen))
@@ -191,3 +204,4 @@ $(eval $(call BuildPackage,libext2fs))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
+$(eval $(call BuildPackage,blkid))