[package] update e2fsprogs to v1.41.5 (#5014)
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index f9f17f4f7ce0fddbfb04bd55fc528dd65437180e..ca5cb082bfc086a218516565eaea1bd8dff73988 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.40.11
+PKG_VERSION:=1.41.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+PKG_MD5SUM:=e218df6c84fc17c1126d31de9472a76c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,7 +26,7 @@ $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libblkid +libuuid
+  DEPENDS:=+libblkid +libuuid +libext2fs
 endef
 
 define Package/e2fsprogs/description
@@ -72,6 +71,17 @@ define Package/libblkid/description
  quickly and easily find block devices by filesystem UUID and LABEL.
 endef
 
+define Package/libext2fs
+$(call Package/e2fsprogs/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=ext2/ext3 filesystem library
+endef
+
+define Package/libext2fs/description
+libext2fs is a library which can access ext2 and ext3 filesystems.
+endef
+
 define Package/tune2fs
 $(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
@@ -90,6 +100,12 @@ $(call Package/e2fsprogs)
   DEPENDS:=e2fsprogs
 endef
 
+define Package/blkid
+$(call Package/e2fsprogs)
+  TITLE:=Command-line utility to locate/print block device attributes
+  DEPENDS:=libuuid libblkid
+endef
+
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
@@ -121,6 +137,10 @@ define Build/InstallDev
                BUILDCC="$(HOSTCC)" \
                DESTDIR="$(1)" \
                install-libs
+       $(MAKE) -C $(PKG_BUILD_DIR)/lib/ext2fs \
+               BUILDCC="$(HOSTCC)" \
+               DESTDIR="$(1)" \
+               install
 endef
 
 define Package/e2fsprogs/install
@@ -130,7 +150,10 @@ define Package/e2fsprogs/install
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(foreach lib,com_err e2p ext2fs,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(CP) $(foreach lib,com_err e2p,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/e2fsck.init $(1)/etc/init.d/e2fsck
+
 endef
 
 define Package/libuuid/install
@@ -148,6 +171,11 @@ define Package/libblkid/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
 endef
 
+define Package/libext2fs/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libext2fs.so* $(1)/usr/lib/
+endef
+
 define Package/tune2fs/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
@@ -163,10 +191,17 @@ define Package/badblocks/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
+define Package/blkid/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/blkid $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,e2fsprogs))
 $(eval $(call BuildPackage,libuuid))
 $(eval $(call BuildPackage,uuidgen))
 $(eval $(call BuildPackage,libblkid))
+$(eval $(call BuildPackage,libext2fs))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
 $(eval $(call BuildPackage,badblocks))
+$(eval $(call BuildPackage,blkid))