[package] use e2fsprogs 1.40.11 with uClibc 0.9.29 (#5085, #5033)
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index 4b2a30b687f93b1030ea60a7f0e088d42530b731..cab4746113231eae2bc5c8b1e59c91622bf16e1b 100644 (file)
@@ -8,12 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.41.3
-PKG_RELEASE:=4
+ifneq ($(CONFIG_UCLIBC_VERSION_0_9_29),y)
+PKG_VERSION:=1.41.5
+PKG_MD5SUM:=e218df6c84fc17c1126d31de9472a76c
+else
+PKG_VERSION:=1.40.11
+PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
+endif
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=b21d26fc46c584021dc9c444933ee1c2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,7 +31,7 @@ $(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3 filesystem utilities
-  DEPENDS:=+libblkid +libuuid +libext2fs
+  DEPENDS:=+libblkid +libuuid +libext2fs +libpthread
 endef
 
 define Package/e2fsprogs/description