e2fsprogs: Update to 1.40.11
[openwrt/svn-archive/archive.git] / package / e2fsprogs / Makefile
index 1543a7bc00ba627b6bdac81d3acad56fc9572756..f9f17f4f7ce0fddbfb04bd55fc528dd65437180e 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,41 +9,84 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=e2fsprogs
-PKG_VERSION:=1.39
+PKG_VERSION:=1.40.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/e2fsprogs
-PKG_MD5SUM:=06f7806782e357797fad1d34b7ced0c6
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=004cea70d724fdc7f1a952dffe4c9db8
 
 include $(INCLUDE_DIR)/package.mk
 
+define Package/e2fsprogs/Default
+  URL:=http://e2fsprogs.sourceforge.net/
+endef
+
 define Package/e2fsprogs
+$(call Package/e2fsprogs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Ext2/3 filesystem utilities
-  DESCRIPTION:=\
-       This package contains essential ext2 filesystem utilities which consists of \\\
-       e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2 \\\
-       filesystem utilities.
-  URL:=http://e2fsprogs.sourceforge.net/
+  DEPENDS:=+libblkid +libuuid
+endef
+
+define Package/e2fsprogs/description
+ This package contains essential ext2 filesystem utilities which consists of 
+ e2fsck, mke2fs, debugfs, dumpe2fs, tune2fs, and most of the other core ext2 
+ filesystem utilities.
+endef
+
+define Package/libuuid
+$(call Package/e2fsprogs/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=DCE compatible Universally Unique Identifier library
+endef
+
+define Package/libuuid/description
+ Library for generating DCE compatible Universally Unique Identifiers.
+endef
+
+define Package/uuidgen
+$(call Package/e2fsprogs)
+  DEPENDS:=libuuid
+  TITLE:=Command line utility to create a new UUID value
+endef
+
+define Package/uuidgen/description
+ uuidgen program creates a new universally unique identifier (UUID) 
+ using the libuuid library. The new UUID can reasonably be considered 
+ unique among all UUIDs created on the local system, and among UUIDs 
+ created on other systems in the past and in the future.
+endef
+
+define Package/libblkid
+$(call Package/e2fsprogs/Default)
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=block device id library
+endef
+
+define Package/libblkid/description
+ The blkid library which allows system programs like fsck and mount to 
+ quickly and easily find block devices by filesystem UUID and LABEL.
 endef
 
 define Package/tune2fs
-  $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem tune utility
-  DESCRIPTION:=Ext2 Filesystem tune utility
   DEPENDS:=e2fsprogs
 endef
 
 define Package/resize2fs
-  $(call Package/e2fsprogs)
+$(call Package/e2fsprogs)
   TITLE:=Ext2 Filesystem resize utility
-  DESCRIPTION:=Ext2 Filesystem resize utility
+  DEPENDS:=e2fsprogs
+endef
+
+define Package/badblocks
+$(call Package/e2fsprogs)
+  TITLE:=Ext2 Filesystem badblocks utility
   DEPENDS:=e2fsprogs
 endef
 
@@ -52,7 +95,13 @@ CONFIGURE_ARGS += \
        --enable-static \
        --disable-rpath \
        --enable-elf-shlibs \
-       --enable-dynamic-e2fsck
+       --enable-dynamic-e2fsck \
+       --disable-tls
+
+define Build/Prepare
+       $(call Build/Prepare/Default)
+       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/config/
+endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/util \
@@ -67,26 +116,57 @@ define Build/Compile
                all install
 endef
 
+define Build/InstallDev
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               BUILDCC="$(HOSTCC)" \
+               DESTDIR="$(1)" \
+               install-libs
+endef
+
 define Package/e2fsprogs/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/e2fsck $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/e2fsck $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mke2fs $(1)/usr/sbin/
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext2
        ln -sf mke2fs $(1)/usr/sbin/mkfs.ext3
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{blkid,com_err,e2p,ext2fs,uuid}.so.* $(1)/usr/lib/
+       $(CP) $(foreach lib,com_err e2p ext2fs,$(PKG_INSTALL_DIR)/usr/lib/lib$(lib).so.*) $(1)/usr/lib/
+endef
+
+define Package/libuuid/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libuuid.so.* $(1)/usr/lib/
+endef
+
+define Package/uuidgen/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uuidgen $(1)/usr/bin/
+endef
+
+define Package/libblkid/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libblkid.so.* $(1)/usr/lib/
 endef
 
 define Package/tune2fs/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/tune2fs $(1)/usr/sbin/
 endef
 
 define Package/resize2fs/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/resize2fs $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/resize2fs $(1)/usr/sbin/
+endef
+
+define Package/badblocks/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,e2fsprogs))
+$(eval $(call BuildPackage,libuuid))
+$(eval $(call BuildPackage,uuidgen))
+$(eval $(call BuildPackage,libblkid))
 $(eval $(call BuildPackage,tune2fs))
 $(eval $(call BuildPackage,resize2fs))
+$(eval $(call BuildPackage,badblocks))