ead: use the new pcap features and the raw socket optimization to eliminate most...
[openwrt/svn-archive/archive.git] / package / ead / Makefile
index 0ecff2a8eda0d14a48aa49ffc2fdeb89c918b636..958577ff90b58917f75c4e612d86693018fa15b0 100644 (file)
@@ -11,8 +11,10 @@ PKG_NAME:=ead
 PKG_RELEASE:=1
 
 PKG_BUILD_DEPENDS:=libpcap
+PKG_BUILD_DIR:=$(BUILD_DIR)/ead
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ead
   SECTION:=net
@@ -29,6 +31,7 @@ endef
 CONFIGURE_PATH = tinysrp
 
 TARGET_CFLAGS += \
+       -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
        -I$(PKG_BUILD_DIR)/tinysrp \
        $(TARGET_CPPFLAGS)