add version number to the banner file as well
[openwrt/svn-archive/archive.git] / package / ebtables / Makefile
index 41c1e0fcda62081ef220712e3cbecc1d32c7dfd3..aef4285d2807b7e792ad1e7035429ddb79fd02f1 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ebtables
-PKG_VERSION:=2.0.8-rc2
+PKG_VERSION:=2.0.8-2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
-PKG_CAT:=zcat
+PKG_MD5SUM:=66bcbcb2dcf3b981ad4e86e1720e796e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
 
@@ -24,10 +23,22 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ebtables
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=+kmod-ebtables
   TITLE:=Ethernet bridge firewall administration utility
   URL:=http://ebtables.sourceforge.net/
 endef
 
+define Package/ebtables/description
+       The ebtables program is a filtering tool for a bridging firewall. The
+       filtering is focussed on the Link Layer Ethernet frame fields. Apart
+       from filtering, it also gives the ability to alter the Ethernet MAC
+       addresses and implement a brouter.
+endef
+
+MAKE_FLAGS += \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LIBDIR="/usr/lib/ebtables"
+
 define Package/ebtables/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/ethertypes $(1)/etc/