[8.09] adjust (sub)release number for packages updated since 8.09.1
[openwrt/svn-archive/archive.git] / package / firewall / Makefile
index 23f23e6dc1fa74b59399f476bee0fa9a167541ed..20bda1a475c51380ea8729d387ac8286bb5ea53b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=1.2
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,11 +18,11 @@ define Package/firewall
   CATEGORY:=Base system
   URL:=http://openwrt.org/
   TITLE:=OpenWrt firewall
-  DEPENDS:=+iptables +iptables-mod-ipopt +iptables-mod-extra
+  DEPENDS:=+iptables-mod-conntrack +iptables-mod-nat
 endef
 
 define Package/firewall/description
firewall for openwrt, you can select if you want to use the old version or the new uci based script
uci based firewall for openwrt
 endef
 
 define Build/Compile
@@ -42,6 +42,8 @@ define Package/firewall/install
        $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/20-firewall $(1)/etc/hotplug.d/iface
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/firewall.user $(1)/etc
 endef
 
 $(eval $(call BuildPackage,firewall))