[package] firewall: prevent excessive uci state data aggregation (#9152)
[openwrt/svn-archive/archive.git] / package / firewall / Makefile
index b6d42cebade4f2ef6b8dec358985deb37cef5183..829719c279151ba9070491826021036d4df0d46d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=12
+PKG_RELEASE:=25
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,6 +18,7 @@ define Package/firewall
   CATEGORY:=Base system
   URL:=http://openwrt.org/
   TITLE:=OpenWrt firewall
+  MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
   DEPENDS:=+iptables +iptables-mod-conntrack +iptables-mod-nat
   PKGARCH:=all
 endef
@@ -32,6 +33,7 @@ endef
 
 define Package/firewall/conffiles
 /etc/config/firewall
+/etc/firewall.user
 endef
 
 define Package/firewall/install
@@ -49,6 +51,8 @@ define Package/firewall/install
        $(INSTALL_DATA) ./files/reflection.hotplug $(1)/etc/hotplug.d/firewall/10-nat-reflection
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/firewall.user $(1)/etc
+       $(INSTALL_DIR) $(1)/lib/upgrade/keep.d
+       $(INSTALL_DATA) ./files/firewall.upgrade $(1)/lib/upgrade/keep.d/firewall
 endef
 
 $(eval $(call BuildPackage,firewall))