remove compatibility crap from libfuse which seems to break on uClibc, because of...
[openwrt/svn-archive/archive.git] / package / fuse / Makefile
index 074d332fb591e1236b46a90444ff28cf800b1ba7..645c1491c4fabc4752588dda40d6252d6600808b 100644 (file)
@@ -35,7 +35,7 @@ define Package/fuse-utils
   $(call Package/fuse/Default)
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libfuse +kmod-fuse
+  DEPENDS:=+libfuse +kmod-fuse @LINUX_2_6
   TITLE+= (utilities)
   DESCRIPTION+=\\\
        \\\
@@ -46,6 +46,7 @@ define KernelPackage/fuse
   SUBMENU:=Filesystems
   $(call Package/fuse/Default)
   TITLE+= (kernel module)
+  DEPENDS:=@LINUX_2_6
   DESCRIPTION+=\\\
        \\\
        This package contains the FUSE kernel module.
@@ -57,12 +58,25 @@ define Package/libfuse
   $(call Package/fuse/Default)
   SECTION:=libs
   CATEGORY:=Libraries
+  DEPENDS:=@LINUX_2_6
   TITLE+= (library)
   DESCRIPTION+=\\\
        \\\
        This package contains the FUSE shared library, needed by other programs.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-kernel-module \
+       --enable-lib \
+       --enable-util \
+       --disable-example \
+       --disable-auto-modprobe \
+       --with-kernel="$(LINUX_DIR)" \
+       --disable-mtab
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                touch configure.in ; \
@@ -70,39 +84,8 @@ define Build/Configure
                touch Makefile.in ; \
                touch include/config.h.in ; \
                touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --enable-kernel-module \
-                       --enable-lib \
-                       --enable-util \
-                       --disable-example \
-                       --disable-auto-modprobe \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --disable-mtab \
-       );
+       )
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
@@ -110,6 +93,8 @@ define Build/Compile
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               AM_CFLAGS="$(TARGET_CFLAGS) -DDISABLE_COMPAT=1" \
+               EXTRA_DIST="" \
                all install
 endef