mac80211: backport latest version from trunk (as of r37265)
[openwrt/svn-archive/archive.git] / package / grub / Makefile
index f3dd171141b9436474561970b8a5762d2d685af8..80b79f29e93a71b096006377a7419728997ec284 100644 (file)
@@ -37,10 +37,6 @@ MY_CONFIGURE_ARGS += \
        --disable-hercules \
        --without-curses \
 
-ifeq ($(HOST_OS),FreeBSD)
-  MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
-endif
-
 MY_CONFIGURE_VARS += \
        grub_cv_prog_objcopy_absolute=yes \
 
@@ -53,6 +49,14 @@ ifeq ($(HOST_OS),Darwin)
   HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
 endif
 
+ifeq ($(HOST_OS),FreeBSD)
+  ifeq ($(HOST_ARCH),amd64)
+    HOST_CFLAGS += $(call host-cc-option,-m32)
+    HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
+    HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)
+  endif
+endif
+
 HOST_CFLAGS += $(call host-cc-option,-fno-stack-protector)
 HOST_CFLAGS += $(call host-cc-option,-U_FORTIFY_SOURCE)
 
@@ -100,7 +104,7 @@ ifeq ($(HOST_ARCH),x86_64)
 endif
 
 $(eval $(call Require,working-gcc-m32, \
-       Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+       Please install 32 bit development files. (gcc-multilib on Debian/Ubuntu, gcc.i686, libgcc.i686, and glibc-devel.i686 on CentOS/Fedora/RHEL) \
 ))
 
 $(eval $(call HostBuild))