remove linux 2.4 support from several packages
[openwrt/svn-archive/archive.git] / package / hostap-driver / Makefile
index 3ea3a25e22586fa38a256a9a94113d3ae04d460e..2b83bda96e2035207be75315c38418e453a3a1a3 100644 (file)
@@ -17,20 +17,9 @@ PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
 PKG_MD5SUM:=c7534dc040ab90218257a78488ecd378
 
 include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
-  -include $(LINUX_DIR)/.config
-endif
-
-define KernelPackage/hostap/Default/2.4
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
-endef
-
-define KernelPackage/hostap/Default/2.6
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
-endef
 
 define KernelPackage/hostap/Default
-$(call KernelPackage/hostap/Default/$(KERNEL))
+  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
   SUBMENU:=Wireless Drivers
   URL:=http://hostap.epitest.fi/
 endef
@@ -45,26 +34,9 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +LINUX_2_6:kmod-lib80211 +wireless-tools
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools
   KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y
-endef
-
-define KernelPackage/hostap/2.4
-# NOTE: needed to remove the dependency on kmod-ieee80211 in the final ipkg
-  DEPENDS:=
-# NOTE: needed to build the standalone version on 2.4
-  KCONFIG:=
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_tkip.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,hostap hostap_crypt_wep hostap_crypt_tkip hostap_crypt_ccmp)
-endef
-
-define KernelPackage/hostap/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap)
 endef
 
@@ -81,18 +53,9 @@ $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCMCIA adaptors
   DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core
   KCONFIG:=CONFIG_HOSTAP_CS
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_cs.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap_cs)
 endef
-define KernelPackage/hostap-cs/2.4
-# NOTE: needed to build the standalone version on 2.4
-  KCONFIG:=
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_cs.$(LINUX_KMOD_SUFFIX)
-endef
-define KernelPackage/hostap-cs/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_cs.$(LINUX_KMOD_SUFFIX)
-endef
 
 define KernelPackage/hostap-cs/description
 $(call KernelPackage/hostap/Default/description)
@@ -105,21 +68,10 @@ $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCI adaptors
   DEPENDS:=@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PCI
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
 endef
 
-define KernelPackage/hostap-pci/2.4
-# NOTE: needed to build the standalone version on 2.4
-  KCONFIG:=
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_pci.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/hostap-pci/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
-endef
-
 define KernelPackage/hostap-pci/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2.5 PCI adaptors.
@@ -131,21 +83,10 @@ $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PLX9052 based PCI adaptors
   DEPENDS:=@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
+  FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
 endef
 
-define KernelPackage/hostap-plx/2.4
-# NOTE: needed to build the standalone version on 2.4
-  KCONFIG:=
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_plx.$(LINUX_KMOD_SUFFIX)
-endef
-
-define KernelPackage/hostap-plx/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
-endef
-
 define KernelPackage/hostap-plx/description
 $(call KernelPackage/hostap/Default/description)
  This package contains the Host AP driver for Prism2/2.5/3 in PLX9052 
@@ -153,25 +94,17 @@ $(call KernelPackage/hostap/Default/description)
 endef
 
 
-ifeq ($(KERNEL),2.4)
-  define Build/Compile
-       $(MAKE) -C $(LINUX_DIR)/ \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               SUBDIRS="$(PKG_BUILD_DIR)/driver/modules" \
-               modules
-  endef
-else
-  define Build/Prepare
+define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
-  endef
-  
-  define Build/Configure
-  endef
-  
-  define Build/Compile
-  endef
-endif
+endef
+
+define Build/Configure
+
+endef
+
+define Build/Compile
+
+endef
 
 define KernelPackage/hostap/install
        $(INSTALL_DIR) $(1)/lib/wifi