mac80211/rt2800: integrate cosmetic changes in rt3352 support
[openwrt/svn-archive/archive.git] / package / hostapd / Makefile
index 492edd71092b7f5a6a1f893abc96bff2d6c69609..122ee9b1a4cf5471073e7155a98e9c164f8cc9cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=20110402
-PKG_RELEASE:=1
-PKG_REV:=4378fc14ebfb355705e7674bf347ea659bcd77bc
+PKG_VERSION:=20120428
+PKG_RELEASE:=2
+PKG_REV:=1f0cc27eb98f7d1af9c64d0752238184cbdb9a24
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=git://w1.fi/srv/git/hostap.git
-PKG_SOURCE_SUBDIR:=hostapd-$(PKG_VERSION)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=fd5e29bbfcb89a4e60fef633bd4efa94
+PKG_MIRROR_MD5SUM:=2732dbca58b0aaaebdad69e13588d058
 
 PKG_BUILD_DEPENDS:= \
        PACKAGE_kmod-madwifi:madwifi \
-       PACKAGE_kmod-mac80211:mac80211 \
 
 PKG_CONFIG_DEPENDS:= \
        CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
@@ -54,6 +53,8 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
 
 include $(INCLUDE_DIR)/package.mk
 
+STAMP_CONFIGURED:=$(STAMP_CONFIGURED)_$(CONFIG_WPA_MSG_MIN_PRIORITY)
+
 ifneq ($(CONFIG_DRIVER_11N_SUPPORT),)
   HOSTAPD_IEEE80211N:=y
 endif
@@ -218,9 +219,9 @@ TARGET_CPPFLAGS := \
        -I$(PKG_BUILD_DIR)/src/crypto \
        $(TARGET_CPPFLAGS) \
        -I$(STAGING_DIR)/usr/include/madwifi \
-       -I$(STAGING_DIR)/usr/include/mac80211 \
        -DCONFIG_LIBNL20 \
-       -D_GNU_SOURCE
+       -D_GNU_SOURCE \
+       $(if $(CONFIG_WPA_MSG_MIN_PRIORITY),-DCONFIG_MSG_MIN_PRIORITY=$(CONFIG_WPA_MSG_MIN_PRIORITY))
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections