disable driver_devicescape in hostapd
[openwrt/svn-archive/archive.git] / package / hostapd / Makefile
index 86ce41457387403121b79c06caec40aef13a6db5..85f42dc6a19761612452c391d4db46a0b680ea95 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=0.5.7
+PKG_VERSION:=0.5.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
-PKG_MD5SUM:=d5113247dc6ee17106e6bc7cb89aa507
+PKG_MD5SUM:=40416b48cae9c78e5a2452caf214aff3
 
 PKG_BUILD_DEPENDS:=madwifi
 
@@ -25,46 +25,55 @@ define Package/hostapd/Default
   CATEGORY:=Network
   TITLE:=IEEE 802.1x Authenticator
   URL:=http://hostap.epitest.fi/
+  DEPENDS:=@!TARGET_avr32 @!TARGET_etrax
 endef
 
 define Package/hostapd
-  $(call Package/hostapd/Default)
-  DEPENDS:=+libopenssl @!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
+$(call Package/hostapd/Default)
   TITLE+= (full)
-  DESCRIPTION:=\
-       This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS \\\
-       Authenticator.
+  DEPENDS+= +libopenssl
 endef
 
 define Package/hostapd/conffiles
 /etc/hostapd.conf
 endef
 
+define Package/hostapd/description
+ This package contains a full featured IEEE 802.1x/WPA/EAP/RADIUS 
+ Authenticator.
+endef
+
 define Package/hostapd-mini
-  $(call Package/hostapd/Default)
-  DEPENDS:=@!LINUX_2_6_AVR32 @!LINUX_2_6_ETRAX
+$(call Package/hostapd/Default)
   TITLE+= (WPA-PSK only)
-  DESCRIPTION:=\
-       This package contains a minimal IEEE 802.1x/WPA/EAP/RADIUS Authenticator \\\
-       (WPA-PSK only).
 endef
 
 define Package/hostapd-mini/conffiles
 /etc/hostapd.conf
 endef
 
+define Package/hostapd-mini/description
+ This package contains a minimal IEEE 802.1x/WPA/EAP/RADIUS Authenticator 
+ (WPA-PSK only).
+endef
+
 define Package/hostapd-utils
   $(call Package/hostapd/Default)
-  DEPENDS:=@PACKAGE_hostapd||PACKAGE_hostapd-mini
   TITLE+= (utils)
-  DESCRIPTION:=\
-       This package contains a command line utility to control the \\\
-       IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
+  DEPENDS:=@PACKAGE_hostapd||PACKAGE_hostapd-mini
+endef
+
+define Package/hostapd-utils/description
+ This package contains a command line utility to control the 
+ IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
 endef
 
 define Build/ConfigureTarget
        $(CP) $(PKG_BUILD_DIR) $(PKG_BUILD_DIR)_$(1)
        $(CP) ./files/$(1).config $(PKG_BUILD_DIR)_$(1)/.config
+ifneq ($(CONFIG_PACKAGE_kmod-madwifi),)
+       echo "CONFIG_DRIVER_MADWIFI=y" >> $(PKG_BUILD_DIR)_$(1)/.config
+endif
 endef
 
 define Build/CompileTarget
@@ -85,7 +94,11 @@ define Package/InstallTemplate
        $(INSTALL_DIR) $$(1)/lib/wifi
        $(INSTALL_DATA) ./files/hostapd.sh $$(1)/lib/wifi/hostapd.sh
        $(INSTALL_DIR) $$(1)/etc
+ifneq ($(CONFIG_PACKAGE_kmod-madwifi),)
        $(INSTALL_CONF) $(PKG_BUILD_DIR)_$(2)/madwifi.conf $$(1)/etc/hostapd.conf
+else
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)_$(2)/hostapd.conf $$(1)/etc/hostapd.conf
+endif
        $(INSTALL_DIR) $$(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)_$(2)/hostapd $$(1)/usr/sbin/
 endef