hotplug2: make it depend on !PROCD_INIT
[openwrt/svn-archive/archive.git] / package / hotplug2 / Makefile
index 898ec3073456249c044f1ec41ce8bacc649ef2df..0746d188165510034bdb6114a8f598bbe281bc3c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,13 +10,14 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=hotplug2
 PKG_REV:=201
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 #PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 #PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
@@ -28,6 +29,7 @@ define Package/hotplug2
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+  DEPENDS:=+USE_EGLIBC:libbsd @!PROCD_INIT
 endef
 
 define Package/hotplug2/description
@@ -44,10 +46,20 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+  TARGET_LDFLAGS += -lbsd
+endif
+
+define Build/Compile
+       $(call Build/Compile/Default)
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+endef
+
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/udevtrigger $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef