util-linux: move package to package/system/utils
[openwrt/svn-archive/archive.git] / package / hotplug2 / Makefile
index de46332500e5b71ac91672cd2505fe0750df0dd9..0746d188165510034bdb6114a8f598bbe281bc3c 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 #PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 #PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
@@ -25,10 +26,10 @@ include $(INCLUDE_DIR)/package.mk
 define Package/hotplug2
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+udevtrigger
   VERSION:=1.0-beta-$(PKG_RELEASE)
   TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+  DEPENDS:=+USE_EGLIBC:libbsd @!PROCD_INIT
 endef
 
 define Package/hotplug2/description
@@ -45,10 +46,20 @@ MAKE_FLAGS += \
        COPTS="$(TARGET_CFLAGS)" \
        STATIC_WORKER="fork"
 
+ifneq ($(CONFIG_USE_EGLIBC),)
+  TARGET_LDFLAGS += -lbsd
+endif
+
+define Build/Compile
+       $(call Build/Compile/Default)
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+endef
+
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/udevtrigger $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef