hotplug2: depend on libbsd only when targetting eglibc
[openwrt/svn-archive/archive.git] / package / hotplug2 / Makefile
index fd9060b2ecf39062f33670803e77288ceaf9b104..6b86c65e18b91209166b81e255e165a68d56f670 100644 (file)
@@ -1,42 +1,65 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hotplug2
-PKG_VERSION:=0.9
-PKG_RELEASE:=3
+PKG_REV:=201
+PKG_VERSION:=$(PKG_REV)
+PKG_RELEASE:=4
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
-PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=hotplug2-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.nomi.cz/svn/isteve/hotplug2
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+#PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
+#PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
   SECTION:=base
   CATEGORY:=Base system
-  VERSION:=0.9+r102-$(PKG_RELEASE)
-  TITLE:=Dynamic device management subsystem for embedded systems
+  VERSION:=1.0-beta-$(PKG_RELEASE)
+  TITLE:=Version 1.0 Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
+  DEPENDS:=+USE_EGLIBC:libbsd
 endef
 
 define Package/hotplug2/description
  Hotplug2 is a trivial replacement of some of the UDev functionality
  in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
+ This is an implementation of Hotplug2-1.0-beta
 endef
 
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES -I."
+define Package/hotplug2/conffiles
+/etc/hotplug2.rules
+endef
+
+MAKE_FLAGS += \
+       COPTS="$(TARGET_CFLAGS)" \
+       STATIC_WORKER="fork"
+
+ifneq ($(CONFIG_USE_EGLIBC),)
+  TARGET_LDFLAGS += -lbsd
+endif
+
+define Build/Compile
+       $(call Build/Compile/Default)
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(PKG_BUILD_DIR)/udevtrigger src/udevtrigger.c
+endef
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/udevtrigger $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef