update to hotplug2 svn version (recommended by iSteve)
[openwrt/svn-archive/archive.git] / package / hotplug2 / Makefile
index 99e277623006cf783a4f9662a8f52dddbe930c7c..ee35bd6fcef24d93fcf5a018b3ff9e2f08636453 100644 (file)
@@ -15,16 +15,13 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://isteve.bofh.cz/~isteve/hotplug2
 PKG_MD5SUM:=ea2c01d027b4002e4e6b0ff266f51a51
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/hotplug2
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=@LINUX_2_6 +udevtrigger
+  VERSION:=0.9+r102-$(PKG_RELEASE)
   TITLE:=Dynamic device management subsystem for embedded systems
   URL:=http://isteve.bofh.cz/~isteve/hotplug2/
 endef
@@ -33,8 +30,11 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
 
 define Package/hotplug2/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/hotplug2.rules $(1)/etc/
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hotplug2 $(1)/sbin/
 endef