[ifxmips]
[openwrt/svn-archive/archive.git] / package / ifxmips-dsl-api / Makefile
index 7214a1c956fc9b99a40fbce4e374028ddbdb6399..aeaec6f29616e583212ee465371a60f698a9ec42 100644 (file)
@@ -12,14 +12,14 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=ifxmips-dsl-api
 PKG_BASE_NAME:=drv_dsl_cpe_api_danube
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/drv_dsl_cpe_api-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
 PKG_MD5SUM:=c45bc531c1ed2ac80f68fb986b63bb87
 
 ifeq ($(DUMP),)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_IFXMIPS_DSL_' $(TOPDIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_IFXMIPS_DSL_' $(TOPDIR)/.config | md5s)
 endif
 
 FW_BASE_NAME:=dsl_danube_firmware_adsl
@@ -41,10 +41,10 @@ define KernelPackage/ifxmips-dsl-api
   TITLE:=DSL CPE API driver
   URL:=http://www.infineon.com/
   MAINTAINER:=Infineon Technologies AG / Lantiq / John Crispin <blogic@openwrt.org>
-  DEPENDS:=@TARGET_ifxmips +kmod-atm @BROKEN
-  FILES:=$(PKG_BUILD_DIR)/src/mei/ifxmips_mei.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/src/mei/ifxmips_atm.$(LINUX_KMOD_SUFFIX)
+  DEPENDS:=@TARGET_ifxmips +kmod-atm
+  FILES:=$(PKG_BUILD_DIR)/src/mei/ifxmips_mei.ko \
+       $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.ko \
+       $(PKG_BUILD_DIR)/src/mei/ifxmips_atm.ko
   AUTOLOAD:=$(call AutoLoad,50,ifxmips_mei drv_dsl_cpe_api ifxmips_atm)
   MENU:=1
 endef