the bison prereq check is no longer necessary
[openwrt/svn-archive/archive.git] / package / iproute2 / Makefile
index 7cbc903da7b36af0159c424c33d93b9050791e25..4fd34f20bb1c2cde9ba040f38fcc321f803f82c9 100644 (file)
@@ -4,17 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.23
+PKG_VERSION:=2.6.25
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_MD5SUM:=2e59da739ef19990408cf0a5cb0cae3e
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=5737bade2f5e03fad0e2c81da91e551e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 
@@ -60,6 +59,8 @@ endef
 
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
@@ -77,6 +78,4 @@ $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
 
-$(eval $(call RequireCommand,bison, \
-       $(PKG_NAME) requires GNU bison. \
-))
+