the bison prereq check is no longer necessary
[openwrt/svn-archive/archive.git] / package / iproute2 / Makefile
index 882819483896669a5d3022fd86769c703cc94b72..4fd34f20bb1c2cde9ba040f38fcc321f803f82c9 100644 (file)
@@ -4,18 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.20-070313
+PKG_VERSION:=2.6.25
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_MD5SUM:=7bc5883aadf740761fa2dd70b661e8cc
-PKG_BUILD_DIR:=$(BUILD_DIR)/iproute-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=5737bade2f5e03fad0e2c81da91e551e
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,17 +26,17 @@ define Package/iproute2/Default
 endef
 
 define Package/ip
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Routing control utility
 endef
 
 define Package/tc
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Traffic control utility
 endef
 
 define Package/genl
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=General netlink utility frontend
 endef
 
@@ -59,6 +59,8 @@ endef
 
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
@@ -76,6 +78,4 @@ $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
 
-$(eval $(call RequireCommand,bison, \
-       $(PKG_NAME) requires GNU bison. \
-))
+