udevtrigger: replace the non-portable tar options used to prevent a namespace conflic...
[openwrt/svn-archive/archive.git] / package / iproute2 / Makefile
index 645d0349f496e584c1e546d279e180cc021ce6d3..da18b4b0fc6b86d869098299090eecfc85fd3829 100644 (file)
@@ -4,18 +4,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
-PKG_VERSION:=2.6.15-060110
+PKG_VERSION:=2.6.29-1
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://developer.osdl.org/dev/iproute2/download/
-PKG_MD5SUM:=04f57a6d366d36426d276178b600f5c5
-PKG_CAT:=zcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://devresources.linux-foundation.org/dev/iproute2/download/
+PKG_MD5SUM:=c1bc258a6c345905e79935ac7a3cc582
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/iproute2-$(PKG_VERSION)
 
@@ -28,15 +26,20 @@ define Package/iproute2/Default
 endef
 
 define Package/ip
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Routing control utility
 endef
 
 define Package/tc
-  $(call Package/iproute2/Default)
+$(call Package/iproute2/Default)
   TITLE:=Traffic control utility
 endef
 
+define Package/genl
+$(call Package/iproute2/Default)
+  TITLE:=General netlink utility frontend
+endef
+
 define Build/Configure
        $(SED) "s:-O2:${TARGET_CFLAGS}:g" $(PKG_BUILD_DIR)/Makefile
        $(SED) "s,-I/usr/include/db3,," $(PKG_BUILD_DIR)/Makefile
@@ -54,8 +57,17 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
+endef
+
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/iproute2
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/iproute2/rt_tables $(1)/etc/iproute2
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
 endef
 
@@ -64,5 +76,13 @@ define Package/tc/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/tc/tc $(1)/usr/sbin/
 endef
 
+define Package/genl/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
+endef
+
 $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,tc))
+$(eval $(call BuildPackage,genl))
+
+