various configure related cleanups
[openwrt/svn-archive/archive.git] / package / ipsec-tools / Makefile
index feccbbb5eb8fabcfd04e72d298156d9a984eab71..67772f126c229f7987f58125954f14fd2ea477dc 100644 (file)
@@ -31,15 +31,7 @@ define Package/ipsec-tools
   URL:=http://ipsec-tools.sourceforge.net/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               configure.ac \
-               aclocal.m4 \
-               Makefile.in \
-               config.h.in \
-               configure \
-       );
-       $(call Build/Configure/Default, \
+CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
                --with-kernel-headers="$(LINUX_DIR)/include" \
@@ -48,8 +40,17 @@ define Build/Configure
                --without-libradius \
                --without-libpam \
                --enable-dpd \
-               --enable-natt \
+               --enable-natt
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.ac \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
        );
+       $(call Build/Configure/Default)
 endef
 
 # override CFLAGS holding "-Werror" that break builds on compile warnings
@@ -62,7 +63,7 @@ endef
 
 define Package/ipsec-tools/install
        $(INSTALL_DIR) $(1)/etc
-       install -m0600 $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipsec.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libracoon.so.* $(1)/usr/lib/