Upgrade ipset to 2.2.9a, fix compilation errors with it (#1848)
[openwrt/svn-archive/archive.git] / package / ipset / Makefile
index 3b53858601275d6e96575de33809a01951e1ce8d..f472d0c9b96dcc73eafde1d02fbdd47b84bb2708 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipset
-PKG_VERSION:=2.2.3
+PKG_VERSION:=2.2.9a
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20050914.tar.bz2
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-20061009.tar.bz2
 PKG_SOURCE_URL:=http://ipset.netfilter.org
-PKG_MD5SUM:=1709424cc2cdb925d4fb6fd5fcaefc26
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=74ce3226b30cdd386630250bdc3488ef
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,6 +29,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" \
+               PREFIX="/usr" \
        )
 endef