more use of the INSTALL_DIR variable
[openwrt/svn-archive/archive.git] / package / iptables / Makefile
index 300ea7fdd0e401698a657e579d51ce09bf59e523..6e486df925c58edb1d3231a10df01549d7e3d084 100644 (file)
@@ -241,7 +241,8 @@ define BuildPlugin
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
-L7_INSTALL:=mkdir -p $$(1)/etc/l7-protocols; \
+L7_INSTALL:=\
+       $(INSTALL_DIR) $$(1)/etc/l7-protocols; \
        $(CP) files/l7/*.pat $$(1)/etc/l7-protocols/
 
 $(eval $(call BuildPackage,iptables))