more use of the INSTALL_DIR variable
[openwrt/svn-archive/archive.git] / package / iptables / Makefile
index 76014aa141ac3eaca9fe03639a3123e55bf8ed99..6e486df925c58edb1d3231a10df01549d7e3d084 100644 (file)
@@ -74,7 +74,7 @@ endef
 
 define Package/iptables-mod-imq
   $(call Package/iptables/Default)
-  DEPENDS:=iptables
+  DEPENDS:=iptables +kmod-ipt-imq
   TITLE:=IMQ support
   DESCRIPTION:=\
        iptables extension for IMQ support.\\\
@@ -173,7 +173,7 @@ define Build/Compile
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install install-devel
+               all install
 endef
 
 define Build/InstallDev
@@ -182,12 +182,21 @@ define Build/InstallDev
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
                DESTDIR="$(STAGING_DIR)" \
-               install install-devel
+               install-devel
+       $(CP) $(PKG_BUILD_DIR)/include $(STAGING_DIR)/usr
+       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(STAGING_DIR)/usr/lib
 endef
 
 define Build/UninstallDev
        rm -rf $(STAGING_DIR)/usr/include/libipq.h
+       rm -rf $(STAGING_DIR)/usr/include/libipulog
+       rm -rf $(STAGING_DIR)/usr/include/libipq
+       rm -rf $(STAGING_DIR)/usr/include/libiptc
+       rm -rf $(STAGING_DIR)/usr/include/linux/netfilter*
+       rm -rf $(STAGING_DIR)/usr/include/iptables*
+       rm -rf $(STAGING_DIR)/usr/include/ip6tables*
        rm -rf $(STAGING_DIR)/usr/lib/libipq.a
+       rm -rf $(STAGING_DIR)/usr/lib/libiptc.a
 endef
 
 define Package/iptables/install
@@ -232,7 +241,8 @@ define BuildPlugin
   $$(eval $$(call BuildPackage,$(1)))
 endef
 
-L7_INSTALL:=mkdir -p $$(1)/etc/l7-protocols; \
+L7_INSTALL:=\
+       $(INSTALL_DIR) $$(1)/etc/l7-protocols; \
        $(CP) files/l7/*.pat $$(1)/etc/l7-protocols/
 
 $(eval $(call BuildPackage,iptables))