we don't need the libiptc library
[openwrt/svn-archive/archive.git] / package / iptables / Makefile
index 80646cd667ce690de55c8923b81dd4002b807585..cfce37769ceff86b17e5f8ce90e58b2abc93a160 100644 (file)
@@ -1,24 +1,37 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
-PKG_VERSION:=1.3.8
-PKG_RELEASE:=2
+
+ifeq ($(CONFIG_LINUX_2_4),y)
+  PKG_VERSION:=1.3.8
+  PKG_RELEASE:=4
+  PKG_MD5SUM:=0a9209f928002e5eee9cdff8fef4d4b3
+  MAKE_TARGETS:=experimental install-experimental install-devel
+endif
+
+ifeq ($(CONFIG_LINUX_2_6),y)
+  PKG_VERSION:=1.4.3.2
+  PKG_RELEASE:=1
+  PKG_MD5SUM:=545698693b636cfc844aafc6729fd48a
+endif
+
+PKG_VERSION?=<IPTABLES_VERSION>
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
-PKG_MD5SUM:=0a9209f928002e5eee9cdff8fef4d4b3
+
+PATCH_DIR:=./patches/$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 ifeq ($(DUMP),)
@@ -33,25 +46,47 @@ define Package/iptables/Default
   URL:=http://netfilter.org/
 endef
 
+define Package/iptables/Module
+$(call Package/iptables/Default)
+  DEPENDS:=iptables $(1)
+endef
+
 define Package/iptables
 $(call Package/iptables/Default)
   TITLE:=IPv4 firewall administration tool
   MENU:=1
+  DEPENDS+= +kmod-ipt-core
 endef
 
-define Package/iptables/conffiles
-/etc/config/firewall
-/etc/firewall.user
+define Package/iptables/description
+ IPv4 firewall administration tool.
+ Includes support for:
+ - limit
+ - LOG
+ - mac
+ - multiport
+ - REJECT
+ - TCPMSS
 endef
 
 define Package/iptables-mod-conntrack
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-conntrack
-  TITLE:=connection tracking modules
+$(call Package/iptables/Module, +kmod-ipt-conntrack)
+  TITLE:=Basic connection tracking extensions
 endef
 
 define Package/iptables-mod-conntrack/description
- iptables extensions for connection tracking.
+ Basic iptables extensions for connection tracking.
+ Includes:
+ - state
+endef
+
+define Package/iptables-mod-conntrack-extra
+$(call Package/iptables/Module, +kmod-ipt-conntrack-extra)
+  TITLE:=Extra connection tracking extensions
+endef
+
+define Package/iptables-mod-conntrack-extra/description
+ Extra iptables extensions for connection tracking.
  Includes:
  - libipt_conntrack
  - libipt_helper
@@ -59,39 +94,36 @@ define Package/iptables-mod-conntrack/description
 endef
 
 define Package/iptables-mod-filter
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-filter
-  TITLE:=filter modules
+$(call Package/iptables/Module, +kmod-ipt-filter)
+  TITLE:=Content inspection extensions
 endef
 
 define Package/iptables-mod-filter/description
  iptables extensions for packet content inspection.
- Includes: 
- - libipt_ipp2p
- - libipt_layer7 
+ Includes:
+ - libipt_string
+ - libipt_layer7
 endef
 
 define Package/iptables-mod-imq
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-imq
+$(call Package/iptables/Module, +kmod-ipt-imq @!LINUX_2_6_27)
   TITLE:=IMQ support
 endef
 
 define Package/iptables-mod-imq/description
  iptables extension for IMQ support.
- Includes: 
+ Includes:
  - libipt_IMQ
 endef
 
 define Package/iptables-mod-ipopt
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-ipopt
-  TITLE:=IP/Packet option modules
+$(call Package/iptables/Module, +kmod-ipt-ipopt)
+  TITLE:=IP/Packet option extensions
 endef
 
 define Package/iptables-mod-ipopt/description
- iptables extensions for matching/changing IP packet options.\\\
- Includes: 
+ iptables extensions for matching/changing IP packet options.
+ Includes:
  - libipt_CLASSIFY
  - libipt_dscp/DSCP
  - libipt_ecn/ECN
@@ -102,116 +134,128 @@ define Package/iptables-mod-ipopt/description
  - libipt_tcpmms
  - libipt_tos/TOS
  - libipt_ttl/TTL
- - libipt_unclean 
+ - libipt_unclean
 endef
 
 define Package/iptables-mod-ipsec
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-ipsec
-  TITLE:=IPSec extensions
+$(call Package/iptables/Module, +kmod-ipt-ipsec)
+  TITLE:=IPsec extensions
 endef
 
 define Package/iptables-mod-ipsec/description
  iptables extensions for matching ipsec traffic.
- Includes: 
+ Includes:
  - libipt_ah
  - libipt_esp
  - libipt_policy
 endef
 
 define Package/iptables-mod-nat
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-nat
-  TITLE:=extra NAT targets
+$(call Package/iptables/Module, +kmod-ipt-nat)
+  TITLE:=Basic NAT extensions
 endef
 
 define Package/iptables-mod-nat/description
- iptables extensions for different NAT targets.
- Includes: 
- - libipt_REDIRECT
+ iptables extensions for basic NAT targets.
+ Includes:
+ - MASQUERADE
+ - SNAT
+ - DNAT
+endef
+
+define Package/iptables-mod-nat-extra
+$(call Package/iptables/Module, +kmod-ipt-nat-extra)
+  TITLE:=Extra NAT extensions
+endef
+
+define Package/iptables-mod-nat-extra/description
+ iptables extensions for extra NAT targets.
+ Includes:
+ - REDIRECT
 endef
 
 define Package/iptables-mod-ulog
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-ulog
+$(call Package/iptables/Module, +kmod-ipt-ulog)
   TITLE:=user-space packet logging
 endef
 
 define Package/iptables-mod-ulog/description
  iptables extensions for user-space packet logging.
- Includes: 
+ Includes:
  - libipt_ULOG
 endef
 
 define Package/iptables-mod-iprange
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-iprange
-  TITLE:=ip range module
+$(call Package/iptables/Module, +kmod-ipt-iprange)
+  TITLE:=IP range extension
 endef
 
 define Package/iptables-mod-iprange/description
  iptables extensions for matching ip ranges.
- Includes: 
+ Includes:
  - libipt_iprange
 endef
 
 define Package/iptables-mod-extra
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-extra
-  TITLE:=other extra iptables extensions
+$(call Package/iptables/Module, +kmod-ipt-extra)
+  TITLE:=Other extra iptables extensions
 endef
 
 define Package/iptables-mod-extra/description
  other extra iptables extensions.
- Includes: 
- - libipt_limit
+ Includes:
  - libipt_owner
  - libipt_physdev
  - libipt_pkttype
  - libipt_recent
  - iptable_raw
  - libipt_NOTRACK
- - libipt_TARPIT
- - libipt_DELUDE
- - libipt_CHAOS
 endef
 
 define Package/iptables-mod-ipset
-$(call Package/iptables/Default)
-  DEPENDS:=iptables +kmod-ipt-ipset
-  TITLE:=ipset iptables extension
+$(call Package/iptables/Module, +kmod-ipt-ipset)
+  TITLE:=IPset extension
 endef
 
 define Package/iptables-utils
-$(call Package/iptables/Default)
-  DEPENDS:=iptables
+$(call Package/iptables/Module, )
   TITLE:=iptables save and restore utilities
 endef
 
 define Package/ip6tables
 $(call Package/iptables/Default)
-  DEPENDS:=+kmod-ipv6
-  CATEGORY:=Network
+  DEPENDS:=+kmod-ip6tables
+  CATEGORY:=IPv6
   TITLE:=IPv6 firewall administration tool
+  MENU:=1
 endef
 
 define Package/ip6tables-utils
  $(call Package/iptables/Default)
  DEPENDS:=ip6tables
- CATEGORY:=Network
+ CATEGORY:=IPv6
  TITLE:=ip6tables save and restore utilities
 endef
 
 define Build/Prepare
        $(call Build/Prepare/Default)
-       chmod a+x $(PKG_BUILD_DIR)/extensions/.*-test*
 endef
 
-define Build/Configure
+ifeq ($(KERNEL),2.4)
+  define Build/Configure
+       chmod a+x $(PKG_BUILD_DIR)/extensions/.*-test*
        rm -f $(PKG_BUILD_DIR)/.configured*
        $(MAKE) -C $(PKG_BUILD_DIR) \
                clean
-endef
+  endef
+endif
+
+TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
+TARGET_CFLAGS += $(FPIC)
+CONFIGURE_ARGS += \
+       --enable-devel \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-xtlibdir=/usr/lib/iptables
 
 define Build/Compile
        mkdir -p $(PKG_INSTALL_DIR)
@@ -220,46 +264,26 @@ define Build/Compile
                COPT_FLAGS="$(TARGET_CFLAGS)" \
                LDFLAGS="-rdynamic -static-libgcc" \
                KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
+               KBUILD_OUTPUT="$(LINUX_DIR)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all experimental install install-experimental
+               all install $(MAKE_TARGETS)
 endef
 
 define Build/InstallDev
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               COPT_FLAGS="$(TARGET_CFLAGS)" \
-               KERNEL_DIR="$(LINUX_DIR)" PREFIX=/usr \
-               DESTDIR="$(1)" \
-               install-devel
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/include $(1)/usr
-       $(CP) $(PKG_BUILD_DIR)/libiptc/libiptc.a $(1)/usr/lib
-endef
-
-define Build/UninstallDev
-       rm -rf $(1)/usr/include/libipq.h
-       rm -rf $(1)/usr/include/libipulog
-       rm -rf $(1)/usr/include/libipq
-       rm -rf $(1)/usr/include/libiptc
-       rm -rf $(1)/usr/include/linux/netfilter*
-       rm -rf $(1)/usr/include/iptables*
-       rm -rf $(1)/usr/include/ip6tables*
-       rm -rf $(1)/usr/lib/libipq.a
-       rm -rf $(1)/usr/lib/libiptc.a
 endef
 
 define Package/iptables/install
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
-       $(INSTALL_BIN) ./files/firewall.user $(1)/etc/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_DATA) ./files/firewall.awk $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-               $(CP) $(patsubst %,lib%.so,$(IPT_BUILTIN:xt_%=ipt_%)) $(1)/usr/lib/iptables/ \
+               for m in $(patsubst xt_%,ipt_%,$(IPT_BUILTIN)) $(patsubst ipt_%,xt_%,$(IPT_BUILTIN)); do \
+                       if [ -f $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$${m}.so ]; then \
+                               $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$${m}.so $(1)/usr/lib/iptables/ ;\
+                       fi; \
+               done \
        )
 endef
 
@@ -285,8 +309,10 @@ endef
 define BuildPlugin
   define Package/$(1)/install
        $(INSTALL_DIR) $$(1)/usr/lib/iptables
-       for m in $$(patsubst xt_%,ipt_%,$(2)); do \
-               $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so $$(1)/usr/lib/iptables/ ; \
+       for m in $(patsubst xt_%,ipt_%,$(2)) $(patsubst ipt_%,xt_%,$(2)); do \
+               if [ -f $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so ]; then \
+                       $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables/lib$$$$$$$${m}.so $$(1)/usr/lib/iptables/ ; \
+               fi; \
        done
        $(3)
   endef
@@ -301,6 +327,7 @@ L7_INSTALL:=\
 $(eval $(call BuildPackage,iptables))
 $(eval $(call BuildPackage,iptables-utils))
 $(eval $(call BuildPlugin,iptables-mod-conntrack,$(IPT_CONNTRACK-m)))
+$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-extra,$(IPT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipset,$(IPT_IPSET-m)))
 $(eval $(call BuildPlugin,iptables-mod-filter,$(IPT_FILTER-m),$(L7_INSTALL)))
@@ -308,6 +335,7 @@ $(eval $(call BuildPlugin,iptables-mod-imq,$(IPT_IMQ-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipopt,$(IPT_IPOPT-m)))
 $(eval $(call BuildPlugin,iptables-mod-ipsec,$(IPT_IPSEC-m)))
 $(eval $(call BuildPlugin,iptables-mod-nat,$(IPT_NAT-m)))
+$(eval $(call BuildPlugin,iptables-mod-nat-extra,$(IPT_NAT_EXTRA-m)))
 $(eval $(call BuildPlugin,iptables-mod-iprange,$(IPT_IPRANGE-m)))
 $(eval $(call BuildPlugin,iptables-mod-ulog,$(IPT_ULOG-m)))
 $(eval $(call BuildPackage,ip6tables))